Tuesday, May 13, 2008

Bug en Debian


Se ha descubierto por Luciano Bello, que el generador de números aleatorios del paquete openssl de Debian es predecible, lo que implica una debilidad criptográfica bastante importante.

Las claves afectadas incluyen las claves SSH, OpenVPN, DNSSEC, y las usadas en los certificados X.509 y en las sesiones SSL/TLS. Las claves generadas con GnuPG o GNUTLS no está afectadas.

Mas información en [Barrapunto].

Actualización: 05/13 17:11 GMT por inniyah: Zak B. Elep enlaza en su bitácora con un programa que permite comprobar fácilmente si nuestras claves públicas OpenSSH o OpenVPN son lo suficientemente débiles como para que necesiten ser reemplazadas. Además indica cómo regenerar las claves RSA y DSA del servidor openssh-server, lo que es bastante recomendable.

Actualización:
05/13 20:21 GMT por inniyah: Resumen para el usuario final de los programas afectados y cómo afrontar el problema.